Wednesday, June 9, 2010

Liferay 6 - RC 2 - Review

Liferay clean install running on Port 8080. Mostly done on IE 8.

Note: This isn't a post of 'answers'. I wrote this blog as I was exploring/trying to figure things out.

Firefox has a HUGE problem with the Add -> More... No applications are showing up from Guest (all I see is a loading image that quickly vanishes). Tried it in the 7 Cogs area thinking it might be a theme issue but I have the same problem (Gecko/2009122116 Firefox/3.0.17).

Out of the box, the innitial visual offering is nice with some reorganized features but firstly, I had to check-out the 'candy' which is in the Control Panel.

Custom Fields

Great! It really helps time-wise to be able to add in extra fields and not have to chase down JSP's and create a hook for these simple types of changes. One thing that would have been nice is to have this type of injection in the Create Account page. I created a field under "User". In the Control Panel under My Account is "Custom Attributes" under the Miscellaneous section. This is unfortunate since many of our clients want one screen (in Details) to have all configurable account information for simplicity sake.

The field types are very robust which is handy however, the "Selection of Text Values" is a bit confusing. Although I know what it means, it doesn't provide an (obvious) way to include the selectable items.

Overall, glad to have it and I'm pretty sure I'll be using it.

Page Templates

The concept is good however, there's a bit of a disconnect. To edit a template, it opens in a new window. Presumably, you make whatever changes you want. I would expect there to be a Save button somewhere in there but since there's none I can only assume you close the window and click the Save button on the original page? Using the "Blog" page as a starting point, after the edit I created a new page with "Blog" as the template however, when the Blog page is viewed normally, the changes are not present. I went back in to the Control Panel and selected to edit the template again. My changes were still there, so why isn't it live on the site?

The steps above worked when I created a new template but I can't seem to make the editing work. I also tried rebooting Tomcat to no avail.

Something else to note, that when you're adding Web Content, none of the articles are displayed. ("No Web Content was found.") I did find how to add it by clicking the Advanced link. The My Places selection box was set to Global which to me, would mean ALL articles but I actually had to set it to "".

Now I know what's going on with the editing. A page with the original template will always have that original view. In order to see the updated page template, you have to create a brand new page and put the template on it to see the changes. This isn't very convenient.


Love it! Disappointed that the Email Notifications section still doesn't allow multilingual. Another REALLY nice feature would have been BCC support. Many of our clients want to know when a new account has been created so BCC'ing the client's email address would have been the simplest way to do it.


I got a surprise in the Monitoring section. It said to enable the monitoring to set the variable live.users.enabled to true. Why wasn't a bool field just included to turn it off or on? (Ya, I'm greedy) So I'm assuming this property has to be set in portal-ext so I set it there and rebooted Tomcat but the message still comes up.

Server Administration

Looking forward to trying out the Data Migration capabilities. Database section is a no brainer but it's too bad there wasn't one of those question mark icons (help) for the repository option.

Source Goodies

As a developer, I think it's great that it's so easy to see how the experts created the site templates programatically (because I will probably have to steal it... Ssssh).

New Web Content

The buttons look horrible in the editor. I'm guessing fckeditor is still the default but I've never seen them look so bad.

Off the bat, I didn't get the "Edit" button in the Structure location and it looks somewhat odd (lack of real-estate). Very surprised to see how robust the form controls were. I like the drag'n'drop. I suspected that a structure was being created which is nice that it's not a 2-step process however, when I click on Save or Publish it says that I should "save the structure first". When I selected OK, it allowed me to enter data for the structure. Then I clicked Publish and I was told to create a template. I clicked the "Select" button in the Template section and was told that changing it would change the structure, available input fields, and available templates. I chose to proceed.

This somewhat feels like I'm having a carrot dangled in front of me. I thought having the option to create forms etc... on the fly was cool but it's not saving me any work. I have to go through all the template vm programming to make it work anyway (hey, I said I was lazy!)

So I'm in the New Template area. I've entered in the required Id, description and associated my structure but now I've launched the editor and don't have a clue what my field names are so I clicked on the name of my structure and there it is. I grab the names and click the back button (because it opens in the same window) and I get a "Web page has expired" message. Not happy.

Determined to do it, I go through the process again. Close the window and click the Publish button and after all that I get a message telling me to pick a template... Ha! Understandable but ironic.

Here's a question: I've added the Web Content Display portlet to my page, clicked the Configuration icon, selected my web content by clicking on it. At the top, the status message says "Displaying Content:" followed by a new peice of green text ("11459 (Modified)") but the page isn't displaying the new web content until I click the Save button at the bottom of the Configuration page?

Document Library

HUGE UI improvement. Thank you. Thank you. Thank you.

Uploading: Well I'm glad the classic uploader is being displayed automatically for browsers without flash but now that ajax can handle a multiple-file upload, why hasn't this changed?

Image Gallery

Again, HUGE UI improvement but one thing I never understood was why there's a Document Library and Document Library Display and only Image Gallery. The Doc Lib and Image Gallery portlets are fine from a management perspective but to an end user they are still quite drab/sterile. I've created my own and am greatful for the service utils but still, it's kind of surprising.

App Sharing

I was really impressed when Liferay came out with this a few versions back and it's great to see they're continuing to add on more options to this functionality.


Didn't look TOO much into it but one thing I did notice is that the Page Ratings portlet disappears when you switch to French.


Navigation looks like it may have some interesting capabilities.

Last Note

I always check up on Liferay in mobile devices. My flavour of the moment is an iPod Touch 3rd Gen. Safari can't open the site stating "Safari cannot open the page because too many redirects occurred." My console spewed forth:

16:01:29,079 ERROR [CompanyThreadLocal:56] com.liferay.portal.NoSuchCompanyException: No Company exists with the primary key 10112
com.liferay.portal.NoSuchCompanyException: No Company exists with the primary key 10112

I decided to try the 7 Cogs mobile site (/web/7cogs-mobile/home) which gave me the same errors.

Well that's it for day 1. I will now go home and ponder the meaning of the pushpin at the top left...


  1. "Well that's it for day 1. I will now go home and ponder the meaning of the pushpin at the top left..."

    So, any idea of what that little red pushpin does?

  2. I remember it being there but I didn't investigate why.

  3. I guess you may have figured out by now. The push pin is to keep the top bar stick or unstick. So if its pressed the top bar will always show even if you scroll down multiple pages.